ResultFAILURE
Tests 11 failed / 873 succeeded
Started2019-11-07 16:00
Elapsed1h19m
Work namespaceci-op-xix4xnpm
pod4.2.0-0.ci-2019-11-07-155436-aws

Test Failures


openshift-tests Monitor cluster while tests execute 33m19s

go run hack/e2e.go -v -test --test_args='--ginkgo.focus=openshift\-tests\sMonitor\scluster\swhile\stests\sexecute$'
2 error level events were detected during this test run:

Nov 07 16:50:35.165 E ns/openshift-authentication pod/oauth-openshift-b89dd89b8-8zjbn node/ip-10-0-134-107.ec2.internal container=oauth-openshift container exited with code 137 (ContainerStatusUnknown): The container could not be located when the pod was terminated
Nov 07 16:51:53.349 E ns/openshift-ingress pod/router-prometheus-d9b6cdd6d-lnvqm node/ip-10-0-133-192.ec2.internal container=router container exited with code 2 (Error): ics port listening at 0.0.0.0:1936 on HTTP and HTTPS\nI1107 16:50:26.067229       1 router.go:306] Watching "/etc/pki/tls/private" for changes\nE1107 16:50:26.069130       1 haproxy.go:392] can't scrape HAProxy: dial unix /var/lib/haproxy/run/haproxy.sock: connect: no such file or directory\nI1107 16:50:26.096176       1 router.go:561] Router reloaded:\n - Checking http://localhost:80 ...\n - Health check ok : 0 retry attempt(s).\nI1107 16:50:26.096217       1 router.go:255] Router is including routes in all namespaces\nI1107 16:50:26.325767       1 router.go:561] Router reloaded:\n - Checking http://localhost:80 ...\n - Health check ok : 0 retry attempt(s).\nI1107 16:50:31.325137       1 router.go:561] Router reloaded:\n - Checking http://localhost:80 ...\n - Health check ok : 0 retry attempt(s).\nI1107 16:50:36.342065       1 router.go:561] Router reloaded:\n - Checking http://localhost:80 ...\n - Health check ok : 0 retry attempt(s).\nI1107 16:50:41.331537       1 router.go:561] Router reloaded:\n - Checking http://localhost:80 ...\n - Health check ok : 0 retry attempt(s).\nI1107 16:50:46.332174       1 router.go:561] Router reloaded:\n - Checking http://localhost:80 ...\n - Health check ok : 0 retry attempt(s).\nI1107 16:51:05.089534       1 router.go:561] Router reloaded:\n - Checking http://localhost:80 ...\n - Health check ok : 0 retry attempt(s).\nI1107 16:51:10.075830       1 router.go:561] Router reloaded:\n - Checking http://localhost:80 ...\n - Health check ok : 0 retry attempt(s).\nI1107 16:51:22.012757       1 router.go:561] Router reloaded:\n - Checking http://localhost:80 ...\n - Health check ok : 0 retry attempt(s).\nI1107 16:51:26.998603       1 router.go:561] Router reloaded:\n - Checking http://localhost:80 ...\n - Health check ok : 0 retry attempt(s).\nI1107 16:51:32.001163       1 router.go:561] Router reloaded:\n - Checking http://localhost:80 ...\n - Health check ok : 0 retry attempt(s).\nI1107 16:51:44.595447       1 router.go:561] Router reloaded:\n - Checking http://localhost:80 ...\n - Health check ok : 0 retry attempt(s).\n

				
				Click to see stdout/stderrfrom junit_e2e_20191107-171148.xml

Find was mentions in log files


openshift-tests [Feature:Builds] Multi-stage image builds should succeed [Conformance] [Suite:openshift/conformance/parallel/minimal] 1m25s

go run hack/e2e.go -v -test --test_args='--ginkgo.focus=openshift\-tests\s\[Feature\:Builds\]\sMulti\-stage\simage\sbuilds\s\sshould\ssucceed\s\[Conformance\]\s\[Suite\:openshift\/conformance\/parallel\/minimal\]$'
fail [github.com/openshift/origin/test/extended/builds/multistage.go:78]: Build did not succeed: &util.BuildResult{BuildPath:"builds/multi-stage", BuildName:"multi-stage", StartBuildStdErr:"", StartBuildStdOut:"", StartBuildErr:error(nil), BuildConfigName:"", Build:(*v1.Build)(0xc002821880), BuildAttempt:true, BuildSuccess:false, BuildFailure:true, BuildCancelled:false, BuildTimeout:false, LogDumper:(util.LogDumperFunc)(nil), Oc:(*util.CLI)(0xc002af8700)}
Expected
    <bool>: false
to be true
				
				Click to see stdout/stderrfrom junit_e2e_20191107-171148.xml

Filter through log files


openshift-tests [Feature:Builds] result image should have proper labels set Docker build from a template should create a image from "test-docker-build.json" template with proper Docker labels [Suite:openshift/conformance/parallel] 3m3s

go run hack/e2e.go -v -test --test_args='--ginkgo.focus=openshift\-tests\s\[Feature\:Builds\]\sresult\simage\sshould\shave\sproper\slabels\sset\s\sDocker\sbuild\sfrom\sa\stemplate\sshould\screate\sa\simage\sfrom\s\"test\-docker\-build\.json\"\stemplate\swith\sproper\sDocker\slabels\s\[Suite\:openshift\/conformance\/parallel\]$'
fail [github.com/openshift/origin/test/extended/builds/labels.go:78]: Expected
    <bool>: false
to be true
				
				Click to see stdout/stderrfrom junit_e2e_20191107-171148.xml

Filter through log files


openshift-tests [Feature:Builds] result image should have proper labels set S2I build from a template should create a image from "test-s2i-build.json" template with proper Docker labels [Suite:openshift/conformance/parallel] 2m12s

go run hack/e2e.go -v -test --test_args='--ginkgo.focus=openshift\-tests\s\[Feature\:Builds\]\sresult\simage\sshould\shave\sproper\slabels\sset\s\sS2I\sbuild\sfrom\sa\stemplate\sshould\screate\sa\simage\sfrom\s\"test\-s2i\-build\.json\"\stemplate\swith\sproper\sDocker\slabels\s\[Suite\:openshift\/conformance\/parallel\]$'
fail [github.com/openshift/origin/test/extended/builds/labels.go:50]: Expected
    <bool>: false
to be true